Jump to content
Domination: Earth

% Taken on multiple land claims is way off

Recommended Posts

I think this first happened to me Saturday, because I should have over 1000 travel points, and I have about half that now. 

When claiming land or upgrading a structure for the second time in 15 minutes, it's not honoring the percent listed. For example, I am showing it should take 5% of perks points. Instead, it took 330 points (out of about 520). I didn't read it closely enough to catch it before hitting okay. I tried again about an hour later, and it tried to take 330 again. Since I had less than 200 left, it failed. 

Link to post
Share on other sites

I get that, but I guess I haven't been paying close enough attention to what it is actually taking - probably because I normally have only used it when it was 1-2%. Taking a percentage from of what I have makes more sense than taking a percentage of maximum capacity. 

I didn't know there was a cap on perk and travel points, I guess, as I've never run into it. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...