Jump to content
Domination: Earth
S Keillan

Level 10 Base Bug

Recommended Posts

There is a long-time bug in the game that sometimes does not recognize a player has a Level 10 base, even though said player has one. This prevents the player from trading and presumably from engaging in conflict. I am wondering what process is in place that toggles these abilities. Any insights are appreciated.

Share this post


Link to post
Share on other sites

Hey guys,

Really sorry for that, that is an old issue indeed; my task list is overflowing and sometimes it takes a while to investigate a problem. :)

I believe this should now be fixed; please let me know if there's still a block on your account, @Max Siren!

19 hours ago, S Keillan said:

I am wondering what process is in place that toggles these abilities. Any insights are appreciated.

It's a very simple trigger: whenever any base is awarded a new level the system checks whether there are any bases with levels higher than that on your account and if not, records it as the new "high score" (it's recorded separately so that the value never goes down when your bases are being destroyed).
Any relevant abilities check whether this "high score" reached 10 yet and unlock when it is.

I'ts hard to say why this de-synchronization occurred in the first place, but an additional post-level-up check has been added that should (hopefully) resolve this once and for all. * fingers crossed *

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Evidently, carsnow2011 has a level 10 base, but the bug is affecting my ability to trade with them.

Edit: never mind. Looks like I was working off of wrong information.

Edited by S Keillan
Wrong information
  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, RobotWizard9 said:

Addition: We made one ally base visible by turning all filters except for ally lands to off. However both of us get the same error, even though I reached level 10 base.

https://drive.google.com/file/d/14o7yZdVNWqCjKlJDXBcY_mSESUpO3N6O/

 

That's unfortunate, looks like the issue still exists!
Will investigate as soon as I get a chance!

In the meantime, I've applied a manual fix to your account; please let me know if you still have that error. ;)

4 hours ago, RobotWizard9 said:

Confirming, I can't see any of Kelle's bases/lands/outposts. (We are allies)

Is that when using the Track Player feature?
If not, you could simply be too far away; there's a certain visibility radius (around 10km from your current position) for all lands/bases of other players.

If he is missing even when using Track Players, is there a chance that your ally is listed in one of the tabs in "Wars"?
We've come across a few rare scenarios involving allies being at war when engaging in the same battle against another enemy, and that means that they may become invisible to each other in 7 days from the war's start date unless they request a Truce.

Share this post


Link to post
Share on other sites

Looks like it's fixed with RobotWizard as I successfully made an offer for a land. 😊

This bug seems to happen randomly as another player recently upgraded to a level 10 base, and I was able to make a trade right after. I presume that it's not exactly random, but the difference eludes me.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...